cdwriter on with ide-scsi locks up with kernel 2.4

From: Roland Marcus Rutschmann (
Date: Mon Jan 08 2001 - 22:16:14 CET

  • Next message: Martin Bruns: "Scanner"

    Sorry wegen der Sprache, aber ich hatte das für eine Newsgroop geschrieben.
    Vielleicht hat ja hier auch jemand eine Idee?


    I just tried kernel 2.4.0 which works well but for one thing.

    When I try to mount a cd wich is in the burner on /dev/hdc (normal cdrom on
    /dev/hdd) the system locks and I have to do a hard reset. This also happened
    on some tests with cdrecord but not as systematic.

    Everything did work with kernel 2.2.18

    After reading some past messages I tried to compile the ide-scsi into the
    kernel (not as module) which also didn't help.

    Mounting cds in the cdrom works also if I use sr_mod for both drives.

    Here my setup:

    part of /etc/conf.modules:
    options ide-cd ignore=hdc # tell the ide-cd module to ignore hdb
    alias scd0 sr_mod # load sr_mod upon access of scd0
    pre-install sg modprobe ide-scsi # load ide-scsi before sg
    pre-install sr_mod modprobe ide-scsi # load ide-scsi before sr_mod
    pre-install ide-scsi modprobe ide-cd # load ide-cd before ide-scsi

    while booting I get the following:
    Linux version 2.4.0 (root@kog-spm) (gcc version 2.95.3 20001229 (prerelease))
    #2 Sat Jan 6 18:07:15 CET 2001
    pty: 256 Unix98 ptys configured
    Uniform Multi-Platform E-IDE driver Revision: 6.31
    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    VP_IDE: IDE controller on PCI bus 00 dev 39
    VP_IDE: chipset revision 16
    VP_IDE: not 100%% native mode: will probe irqs later
    VP_IDE: VIA vt82c686a IDE UDMA66 controller on pci0:7.1
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings:
    hdc:DMA, hdd:DMA
    hda: Maxtor 94098H6, ATA DISK drive
    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    hdc: RICOH CD-R/RW MP7083A, ATAPI CDROM drive
    hdd: LTN485S, ATAPI CDROM drive
    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    ide1 at 0x170-0x177,0x376 on irq 15

    when I do a modprobe sr_mod I get (as root):

    ide-cd: ignoring drive hdc
    hdd: ATAPI 48X CD-ROM drive, 120kB Cache, DMA
    Uniform CD-ROM driver Revision: 3.12
    hdc: set_drive_speed_status: status=0x51 { DriveReady SeekComplete Error }
    hdc: set_drive_speed_status: error=0x04
    scsi0 : SCSI host adapter emulation for IDE ATAPI devices
      Vendor: RICOH Model: CD-R/RW MP7083A Rev: 1.10
      Type: CD-ROM ANSI SCSI revision: 02
    Detected scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
    sr0: scsi3-mmc drive: 32x/32x writer cd/rw xa/form2 cdda tray

    If I now do "mount -t iso9660 /dev/scd0 /brenner" the system is locked (I
    don't even get a response to a ping command from another computer)

    Any ideas? Need more information? I would be very happy for any help.



    Dr. Roland Marcus Rutschmann <>
    Inst. fuer Kognitionsforschung, Univ. Oldenburg, FB 5/A6, 26111 Oldenburg
    Tel.: 0441 798 2836 Fax: +49 441 7985170,

    This archive was generated by hypermail 2b30 : Mon Jan 08 2001 - 22:16:20 CET