Re: Comments on CD images v4 (was Re: new CD images (II))

From: Michael Bramer (
Date: Thu Jun 14 2001 - 08:33:26 CEST

  • Next message: Michael Bramer: "Re: Comments on CD images v4 (was Re: new CD images (II))"

    On Wed, Jun 13, 2001 at 10:37:36AM +0200, Stefan Gybas wrote:
    > The following packages from testing should be included on the CD:
    > - devfsd (for kernel 2.4)
    > - reiserfsprogs (for kernel 2.4)
    > - pppoe
    > - libapache-mod-ssl (non-US)


    > - zip (why was it removed from v3 to v4?)

    there is zip-ssl on the cd

    > - java-compiler-dummy (if not included, we can remove java-common)
    > - java-virtual-machine-dummy
    > - grub
    > - coldsync
    > - mkisofs (recommended by cdrecord)
    > - krb5-user (non-US, recommended by libkrb53)


    > - netscape-smotif-477 (non-free, and everything it depends on) [1]

    NO. _I_ put no non-free on the CD.

    > The following packages from potato-proposed-updates / unstable should also
    > be included:
    > - boot-floppies 2.2.24 from potato-proposed-updates (contains kernel 2.2.19
    > which is in pool/ on the CD)
    > - pcmcia-modules-2.2.19* from potato-proposed-updates (required by
    > kernel-image-2.2.19*)
    > - lvm and lvm-common (for kernel 2.4)

    ok, I can use this.

    > Some package should be upgraded to the current version in testing, at lease
    > these:
    > - ssh 2.5.2p2 (non-US, instead of the included 2.2.0)
    > - dpkg 1.9.6 (or better 1.9.9 from unstable)
    > - fetchmail-ssl 5.8.3-1 (non-US, depended on by fetchmailconf 5.8.3-1)
    > - gdb 5.0-4 from unstable (recommended by ddd, RC bugs are for non-i386)
    > - mozilla 0.9.1 (M18 is from Sep 2000!) [1]

    ok, I check this

    > These packages should be removed IMHO (all have no reverse dependencies):
    > - libstdc++3.0 (depends on gcc-3.0-base which is not available)
    > - libungif3g-dev (conflicts with libungif4-dev, gdk-imlib-dev depends on
    > either)
    > - qt-designer and uic (both conflict with kde-designer)
    > - aolserver (preinst exits with error 100)
    > - kernel-image-2.2.18pre21* with pcmcia-modules from dists/potato/base
    > (2.2.19 is in pool/ on the CD)
    > - libsdl1.1 (install smpeg-xmms 0.3.4-4 from unstable which depends on
    > libsdl1.2, this is better because libsmpeg0 also depends on libsdl1.2)
    > SDL 1.1 is obsolte and was a decveopment versrion. The maintainer wants
    > to remove in from the archive once all packages are linked aginast SDL 1.2.
    > - expect5.24 (expect 5.31 is still present)
    > - itcl3.0 and itk3.1 (itcl3.1 and itk3.1 are still present)
    > - tcl8.2 and tk8.2 (change task-tcltk to depend on 8.3)
    > - zope-emarket
    > - plugger and all libc5-based libraries: libpng0, libgd1, zlib1, libc5
    > - netscape-base (or include the complete netscape) [1]

    I ckeck this and I will remove thinks. but:
     - I don't make changes on the packages (like 'change task-tcltk to
       depend on 8.3')! This is a snapshot from woody (only kde, gnome and
       BF's are not from woody) and not a 'privat edition' with changes.
       If you have problmes, submit bug reports

    > We should then build a new base2_2.tgz (I can do this if noone else
    > volunteers) with the version from testing instead of potato because
    > upgrading causes some problems:
    > - libc6 now uses /etc/locale-gen, this should be in base.tgz and configured
    > to build at lease de_DE

    I know this. But this is Debian, this is woody and I don't like to
    make a 'undebian' CD. If you Update a potato or if you install a woody
    (with no changes in this area) at release time, you have to change
    this file. If you don't like it, write bug reports or better make a
    script in /usr/lib/base-config/ and send this to the libc6 maintainer.

    > - libc6 wants to restart inetd because of NSS changes

    ok, this is not nice. It is a 'update' problem (from the potato
    BF-system to woody).

    But if you change base2_2.tgz with this, you must build all bin's etc.
    new and use the new lib. This is very critical. Should we use the
    'testet' BF's on our CD or if we want it critical: should we use

    > - I got some requests by dpkg about changes config files (sorry, don't
    > remember which), this IMHO causes confusion to new users

    IMHO you have use 'MD5'-password (the first base-config question) and
    with this a 'change config file question is normal' and debian like.

    > I found some problems with debconf:
    > - I got the message "debconf: cannot preconfigure packages -- apt-utils isi
    > not installed." See #92140 for details.
    > Suggested solution: Put apt-utils in our base.tgz or change debconf's
    > dependencies
    > - libterm-stool-perl is not installed so the Slang frontend does not work
    > Suggested solution: Put libterm-stool-perl in our base.tgz or change
    > debconf's dependencies

    this is a real Problem.

    Now I don't use a override file. But I will test:
     - put apt-utils and libterm-stool-perl as 'required base" in the
       override file. I hope with this, this packages will installed with

    BTW: - This problem is know. joeyh will maybe split apt-utils in to
           package. One for debconf, and a second for the rest.
         - the second is a apt problem! apt get alway only the 'Depends'
           Packages and no 'Recommends' packages. And with this, all
           packges are working, but not in the typically way.

           from /usr/doc/maint-guide/maint-guide.txt.gz:
           'Use this for packages that are not strictly necessary but are
           typically used with your program.#

           IMHO we must fix apt and make a 'Recommends' and 'Suggests'
           Option ...

    > Another problem:
    > - There is an X11 configuration in base (anXoius) and and xserver-xfree86
    > (XFree 4.0.3). But I'll guess there's nothing we can do about this if we
    > want to include XFree 3.3.6 servers.

    can someone write a TOP-Level-README with
     - some Install problems
     - some note about a live after the LTCD? (like apt-setup, apt-setup)


    Michael Bramer  -  a Debian Linux Developer
    PGP: finger  -- Linux Sysadmin   -- Use Debian Linux
    "Das ist das entscheidende Problem. Hirn ist heutzutage eine sehr seltene 
     und teure Resource" -- Ullrich von Bassewitz <>

    -- To UNSUBSCRIBE, email to with a subject of "unsubscribe". Trouble? Contact

    This archive was generated by hypermail 2b30 : Thu Jun 14 2001 - 08:44:17 CEST