Comments on CD images v4 (was Re: new CD images (II))

From: Stefan Gybas (
Date: Wed Jun 13 2001 - 10:37:36 CEST

  • Next message: Eduard Bloch: "Re: Comments on CD images v4 (was Re: new CD images (II))"

    Michael Bramer wrote:

    > Today I upload a new CD image to
    > again.

    I did two test installations which went pretty well but I still have some
    comments and suggestions for improvements:

    The following packages from testing should be included on the CD:

    - devfsd (for kernel 2.4)
    - reiserfsprogs (for kernel 2.4)
    - pppoe
    - libapache-mod-ssl (non-US)
    - zip (why was it removed from v3 to v4?)
    - java-compiler-dummy (if not included, we can remove java-common)
    - java-virtual-machine-dummy
    - grub
    - coldsync
    - mkisofs (recommended by cdrecord)
    - krb5-user (non-US, recommended by libkrb53)
    - netscape-smotif-477 (non-free, and everything it depends on) [1]
    The following packages from potato-proposed-updates / unstable should also
    be included:

    - boot-floppies 2.2.24 from potato-proposed-updates (contains kernel 2.2.19
      which is in pool/ on the CD)
    - pcmcia-modules-2.2.19* from potato-proposed-updates (required by
    - lvm and lvm-common (for kernel 2.4)

    Some package should be upgraded to the current version in testing, at lease

    - ssh 2.5.2p2 (non-US, instead of the included 2.2.0)
    - dpkg 1.9.6 (or better 1.9.9 from unstable)
    - fetchmail-ssl 5.8.3-1 (non-US, depended on by fetchmailconf 5.8.3-1)
    - gdb 5.0-4 from unstable (recommended by ddd, RC bugs are for non-i386)
    - mozilla 0.9.1 (M18 is from Sep 2000!) [1]

    These packages should be removed IMHO (all have no reverse dependencies):

    - libstdc++3.0 (depends on gcc-3.0-base which is not available)
    - libungif3g-dev (conflicts with libungif4-dev, gdk-imlib-dev depends on
    - qt-designer and uic (both conflict with kde-designer)
    - aolserver (preinst exits with error 100)
    - kernel-image-2.2.18pre21* with pcmcia-modules from dists/potato/base
      (2.2.19 is in pool/ on the CD)
    - libsdl1.1 (install smpeg-xmms 0.3.4-4 from unstable which depends on
      libsdl1.2, this is better because libsmpeg0 also depends on libsdl1.2)
      SDL 1.1 is obsolte and was a decveopment versrion. The maintainer wants
      to remove in from the archive once all packages are linked aginast SDL 1.2.
    - expect5.24 (expect 5.31 is still present)
    - itcl3.0 and itk3.1 (itcl3.1 and itk3.1 are still present)
    - tcl8.2 and tk8.2 (change task-tcltk to depend on 8.3)
    - zope-emarket
    - plugger and all libc5-based libraries: libpng0, libgd1, zlib1, libc5
    - netscape-base (or include the complete netscape) [1]

    We should then build a new base2_2.tgz (I can do this if noone else
    volunteers) with the version from testing instead of potato because
    upgrading causes some problems:

    - libc6 now uses /etc/locale-gen, this should be in base.tgz and configured
      to build at lease de_DE
    - libc6 wants to restart inetd because of NSS changes
    - I got some requests by dpkg about changes config files (sorry, don't
      remember which), this IMHO causes confusion to new users

    I found some problems with debconf:

    - I got the message "debconf: cannot preconfigure packages -- apt-utils isi
      not installed." See #92140 for details.
      Suggested solution: Put apt-utils in our base.tgz or change debconf's
    - libterm-stool-perl is not installed so the Slang frontend does not work
      Suggested solution: Put libterm-stool-perl in our base.tgz or change
      debconf's dependencies

    Some more suggestions:

    - Set the default keymap to German (in base-config and console-tools debconf
    - Set the default papersize to a4 (in libpaperg's debconf DB)

    Another problem:

    - There is an X11 configuration in base (anXoius) and and xserver-xfree86
      (XFree 4.0.3). But I'll guess there's nothing we can do about this if we
      want to include XFree 3.3.6 servers.

    [1] Are you really suggesting to include Mozilla M18 (released September 2000)
        instead of Netscape 4.77? If we include Mozilla, we should use 0.9.1,
        I think there was an announcemant on debian-devel about an unoffical
        package recently. I think we should include both: Mozilla is not
        yet usable for most web sites, like online banking.

    Stefan Gybas

    -- To UNSUBSCRIBE, email to with a subject of "unsubscribe". Trouble? Contact

    This archive was generated by hypermail 2b30 : Wed Jun 13 2001 - 10:37:55 CEST